
Help for Mom for Windows v2.0
Mom for Windows is a Personal Information Manager (PIM) that you can use to remind you of important 
things you need to do, and to remember names, addresses, and phone numbers.    It includes:

A Calendar.
An Events database with alarms that can play sound files and run other programs.
A Names database that stores information like names, addresses, and phone numbers.    It can 

even dial the telephone.
A Note Editor. 

For information on how to use Help, press F1 or choose Using Help from the Help menu.
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What's New?
There are too many changes in Mom for Windows version 2.0 to mention them all, but here are some of 
the highlights:

Mom for Windows now uses the Multiple Document Interface (MDI) standard.
Toolbar for commonly used functions.
Customizable Events and Names Viewers.
Events and Names stored in the Microsoft Access database for better reliability, variable length 

fields, and user-defined queries.
Dialog boxes to modify all MOMWIN20.INI options.
Sizable month calendar and new year calendar.
Calendars can be printed.
Print Setup and Page Setup for better printing.
Categories for Events and Names.
Event alarms can play .WAV files and run other programs.
The state of the Calendar, Events Viewer, Names Viewer, and Note Editor can be saved and are 

restored when you run Mom for Windows.
Import/Export Names from/to comma-delimited ASCII text files.
Allow 24 hour time, and honor Windows short and long date formats.
Use prefix option on the autodialer.
Autodialer can be used on pulse-type phones.

See Also
Converting from Mom for Windows version 1.0



Registering
Mom for Windows is distributed as shareware.    It is not free.    You may use it for 30 days before 
registering it.    At the end of the 30-day trial period, you should either register your copy or discontinue 
using Mom for Windows.    To register, complete and print the order/registration form (ORDERFRM.TXT) 
and send it along with $15 (US) to:

Kyle Lutes Computing
P.O.Box 267

Bremen, IN    46506-0267

Upon receiving your order form, we'll send you a copy of the most recent registered user's version of 
Mom for Windows.    The registered user's version won't prompt you to register each time you start and 
exit the application.

Disclaimer:
Users of Mom for Windows must accept this disclaimer of warranty:      Mom for Windows is supplied as is.
The author disclaims all    warranties, expressed or implied, including, without limitation, the warranties of 
merchantability and of fitness for any purpose.    The author assumes no liability for damages, direct or 
consequential,    which may result from the use of Mom for Windows.

If you need to contact the author, you can write to the registration address.    If you have access to 
electronic mail, you can also send mail to the Internet E-Mail address: kdlutes@ualr.edu 

Copyright © 1992-1993 Kyle Lutes Computing

P.O.Box 267

Bremen, IN    46506-0267



Using the Calendar
You can use the Calendar to view one month or one year at a time.    The month view is drawn to fill the 
entire Calendar window each time you change its size.    The year view is fixed size.    The year size can 
change depending on which font is used to draw it.    You can use the scroll bars to see months in the year
view that may exist beyond the borders of the window.    

Mouse Hints
Click the arrow buttons at the top of the window to view the next or previous month or year.
Click the Today button to view the current year or current month with today's date selected.
Click the Year/Month button to toggle between month view and year view.
Double-click a day in the month view to display the Events for that day.
Double-click a day while holding down the Shift key to add an Event for that day.
Double-click a month in the year view to display that month in month view.

Keyboard Hints
Press Page-Up and Page-Down to display the previous and next month.
Press Shift Page-Up and Shift Page-Down to display the previous and next year.
Press the arrow keys while holding the Shift key to select days in the month view.
Select a day in the month view and press Return to display the Events for that day.
Select a day in the month view and press Shift Return to add an Event for that day.

See Also
Calendar Commands



Using Events
An event can be an anniversary, birthday, appointment, holiday, meeting, or any other special event you 
need to remember.    Events can have times and you can set an alarm to remind you of the event.    
Events can run other programs and play sound files.    Menu commands allow you to add events, update 
events, search for events, and query the Events database using SQL statements.

Events are viewed using the Events Viewer.    You can change the contents of the viewer by setting 
options in the Events Options dialog box.    The Events Viewer has four modes:

Up-Coming Events
Displays all up-coming events.    Keyboard Shortcut: Ctrl+U.
Today's Events
Displays all events for today.    Keyboard Shortcut: Ctrl+T.
Selected Date's Events
Displays all events for the date currently selected on the Calendar.    Keyboard Shortcut: Ctrl+S.
All Events
Displays all the events.    Keyboard Shortcut: Ctrl+L.

See Also
Maintaining Events
Advanced Events
Turn Off an Alarm
Events Commands



Maintaining Events
Events are maintained using the Add Event and Update Event dialog boxes.    

To add an Event
Choose Add Event from the Events Menu, or
Press Ctrl+E, or 
Double-click a day in the Calendar while holding down the Shift key, or
Select a day in the month view and press Shift Return, or
Click the Add Event button on the toolbar.

To update an Event
Select an Event from the Events Viewer and choose Update Event from the Events Menu, or
Double-click the event you want to update, or
Select an event and press the Enter key.

To delete an Event
Select an Event from the Events Viewer and choose Delete Event from the Events Menu, or
Double-click the event you want to delete then click the Delete button, or
Select an event, press the Enter key, and click the Delete button.

The Add Event and Update Event dialog boxes consists of:

Desc
A description of the event.

Date
The date of the event.    The date is formatted according to the Windows short date format in the 
International Settings of the Windows Control Panel.    The date defaults to the date selected on the 
Calendar.    You can use the spin buttons or the up and down arrow keys to scroll the date forward and 
backward by one day.

Type
The type of the event.    Available types are:

Once
Daily
Weekly
Monthly
Yearly

An event type of Once, is removed from the database according to the Remove Events Days value in the 
Events Options dialog box.    All other event types are rescheduled according to their type each time you 
start Mom for Windows.

Early Warning Days
The number of days before the event occurs that you want to be notified.    The Events Viewer displays 
Up-Coming Events using this value.    For example, to display an event one week prior to the event, enter 
7 here.    This value defaults to the Early Warning Days value in the Events Options dialog box.

Time
The time of the event.    The time is optional and is formatted according to the time format in the 
International Settings of the Windows Control Panel.    You can use the spin buttons or the up and down 



arrow keys to scroll the time forward and backward by the Time Scroll Increment value in the Events 
Options dialog box.

Alarm
Set this option if you want an Alarm dialog box to display to notify you of the event.    This option can only 
be chosen for events with a time.

Sound
Set this option if you want the Alarm dialog box to beep or play a sound file when notifying you of the 
event.    The alarm will beep or play the sound file the number of times specified by the Beep/Play Sound 
and Number of Beeps settings in the Events Options dialog box.

Early Warning Minutes
The number of minutes before the event occurs that you want to be notified.    For example, to display the 
alarm dialog box 15 minutes prior to the event, enter 15 here.    This value defaults to the Early Warning 
Minutes value in the Events Options dialog box.

Comments
A free-format text area that you can use to include any further information.

Category
See Using Categories for more information.

See Also
Using Events
Advanced Events
Turn Off an Alarm
Events Commands



Advanced Events
Events can optionally perform advanced functions like run other programs and play unique sound files.    
The Add Events and Update Events dialog boxes have the following additional fields:

Command Line
Enter the name of another program here to have it automatically run on the event date and time.    For 
example, suppose you have a program that checks your E-Mail or backs up your hard disk.    You could 
create an event to run this program everyday while you are at lunch.    Just add a daily event with a time 
of 12:00pm, and enter the program name (e.g. C:\BAT\BACKUP.BAT) here.

Run Minimized
Check this box if you want the program entered on the command line to be run minimized.

Sound File
To override the default sound file, enter a new sound file name for this event.    The default sound file is 
specified in the Events Options dialog box.

See Also
Using Events
Maintaining Events
Turn Off an Alarm
Events Commands



Turn Off an Alarm
The alarm dialog box displays when you have created an event with an alarm and the alarm time has 
been reached. 

To turn off the alarm
Click the Off button, or
Click the Snooze button.    The alarm will be reset to go off again in a number of minutes.    The 

number of minutes to snooze depends on the Snooze Minutes value in the Events Options dialog box.

If the Event has the sound indicator set, the alarm clock will beep or play a sound file the number of times 
specified by the Number of Beeps value in the Events Options dialog box.    To silence the beeping alarm 
clock icon, simply click it with the mouse.    Clicking the alarm clock icon a second time will turn the 
beeping alarm clock on again.

See Also
Using Events
Maintaining Events
Advanced Events
Events Commands



Using Names
Names can actually be used to store more than just a person's name.    You can store names, addresses, 
phone numbers, categories, and comments for a person or organization.    Menu commands allow you to 
add names, update names, delete names, search for names, and query the Names database using SQL 
statements.

Names are viewed using the Names Viewer.    Entries are listed in alphabetical order.    Buttons across the
top of the Names Viewer allow you to select only names beginning with a letter of the alphabet.    You can 
change the contents of the viewer by setting options in the Names Options dialog box.

To dial a telephone number from the names viewer, first select the cell containing the telephone number 
and then click the small telephone icon.    If a cell contains more than one telephone number, only the first 
will be dialed.    See Autodial Options for more information.

See Also
Maintaining Names
Names Commands
Importing Names
Exporting Names



Maintaining Names
Names are maintained using the Add Name and Update Name dialog boxes.    

To add a Name
Choose Add Name from the Names Menu, or
Press Ctrl+A, or 
Click the Add Name button on the toolbar.

To update a Name
Select a Name from the Names Viewer and choose Update Name from the Names Menu, or
Double-click the name you want to update, or
Select a name and press the Enter key.

To delete a Name
Select a Name from the Names Viewer and choose Delete Name from the Names Menu, or
Double-click the name you want to delete then click the Delete button, or
Select a name, press the Enter key, and click the Delete button.

The Add Name and Update Name dialog boxes consists of:

Name
The name of the person or organization.

Address
The address of the person or organization.    You can enter up to four lines of addresses.

Copy
Copies the name and address to the Windows' clipboard so you can paste it into other documents.

Phones
Four phone numbers can be entered.    You can enter the phone numbers anyway you like and include a 
description.    For example, 1-800-555-1212 office, or 1(501)555-1212 Fax.

Dial Buttons
Clicking the small telephone icon next to a telephone number sends instructions to your modem to dial 
the telephone number.    See Autodial Options for more information.

User1
User2
These fields can be used to store whatever additional information you like.    For example, E-Mail address 
or maybe Company Name.    You can change the labels for the user-defined fields by changing the 
settings in the Names Options dialog box.

Comments
A free-format text area that you can use to include any further information.

Category
See Using Categories for more information.



See Also
Using Names
Names Commands
Importing Names
Exporting Names



Using Notes
The Note Editor is a simple text editor that works much like the Windows Notepad.    However, it has the 
additional advantages of being automatically loaded and saved whenever you run and exit Mom for 
Windows.    You can use it as a scratch pad to type notes and reminders.

See Also
Notes Commands



Commands
File Commands
Calendar Commands
Events Commands
Names Commands
Notes Commands
Options Commands
Window Commands



File Commands

Print
Prints the contents of the active window.    You can print the Calendar (month or year), Events, Names, 
and Notes.

Page Setup
Displays the Page Setup dialog box.    From it you can specify the margins and font that should be used 
when printing.

Print Setup
Displays the Print Setup dialog box.    From it you can select a printer and change page orientation.

Import Names
Displays the Import Names dialog box.    See Importing Names for more information.

Export Names
Displays the Export Names dialog box.    See Exporting Names for more information.

Exit
Quits Mom for Windows.    All changes that have been made to the Events and Names database and the 
Note Editor are automatically saved.



Calendar Commands

Month
Causes the Calendar to display the selected month.

Year
Causes the Calendar to display the selected year.

See Also
Using the Calendar
Month and Year Fonts



Events Commands

Up-Coming Events
Displays all up-coming events.    Shortcut: Ctrl+U.

Today's Events
Displays all events for today.    Shortcut: Ctrl+T.

Selected Date's Events
Displays all events for the date currently selected on the Calendar.    Shortcut: Ctrl+S.

All Events
Displays all the events.    Shortcut: Ctrl+L.

Query Events
See Using Queries for more information.

Add Event
Displays the Add Event dialog box.    Shortcut: Ctrl+E or double-click a day in the Calendar while holding 
down the Shift key.

Update Event
Displays the Update Event dialog box for the event currently selected on the Events Viewer.    Shortcut: 
Double-click the event you want to update, or select an event and press the Enter key.

Delete Event
Deletes the event currently selected on the Events Viewer.    Shortcut: Double-click the event you want to 
delete or select an event and press the Enter key, then click the Delete button.

Find Event
Displays a dialog box then searches for event descriptions containing the specified characters or words.    
The update dialog box is displayed for any match.    Press F3 or click the Find Next button from the 
Update Event dialog box to find the next match.    Press Shift-F3 or click the Find Prev button from the 
Update Event dialog box to find the previous match.

Categories
See Using Categories for more information.

See Also
Using Events
Maintaining Events
Advanced Events
Turn Off an Alarm
Events Options



Names Commands

View Names List
Displays the Names Viewer.    Shortcut: Ctrl+N.

Query Names
See Using Queries for more information.

Add Name
Displays the Add Name dialog box.    Shortcut: Ctrl+A.

Update Name
Displays the Update Name dialog box for the name currently selected on the Names Viewer.    Shortcut: 
Double-click the name you want to update, or select a name and press the Enter key.

Delete Name
Deletes the name currently selected on the Names Viewer.    Shortcut: Double-click the name you want to 
delete or select a name and press the Enter key, then click the Delete button.    

Find Name
Displays a dialog box then searches for names containing the specified characters or words.    Only the 
name field is searched.    The update dialog box is displayed for any match.    Press F3 or click the Find 
Next button from the update dialog box to find the next match.    Press Shift-F3 or click the Find Prev 
button from the update dialog box to find the previous match.    Shortcut: Ctrl-F.

Categories
See Using Categories for more information.

See Also
Using Names
Maintaining Names
Names Options
Importing Names
Exporting Names



Notes Commands

View
Displays the Notes Editor.    Shortcut: Ctrl-O.

New
Removes everything in the current notes file.

Save
Saves the Notes to disk.    Although the Notes will be automatically saved whenever you exit,    you might 
choose this if you've just made a bunch of changes and you want to make sure they get saved even if 
your system crashes.    Notes can be automatically saved to their file by selecting options on the User 
Setup Options dialog box.

Cut
Deletes text from the Note Editor and places it onto the Clipboard, replacing the previous Clipboard 
contents.    Shortcut: Ctrl+X.

Copy
Copies text from the Note Editor onto the Clipboard, leaving the original intact and replacing the previous 
Clipboard contents.    Shortcut: Ctrl+C.

Paste
Pastes a copy of the Clipboard contents at the insertion point or replaces selected text in the Note Editor.  
Shortcut: Ctrl+V.

Delete
Deletes selected text from the Note Editor, but does not place the text onto the Clipboard.    Use Delete 
when you want to delete text but you have text on the Clipboard that you want to keep. 

Find
Searches for characters or words in the Note Editor.    You can match uppercase and lowercase letters.

Find Next
Repeats the last search without opening the Find dialog box.

See Also
Using Notes



Options Commands

User Setup
This command displays the User Setup Options dialog box.    Buttons on this dialog box allow you to 
change the Autodial Options, Events Options, Names Options, Month and Year Fonts, and Categories 
dialog boxes.

Save Settings Now
Saves the current system settings.    Choosing this selection is the same as:

Setting the Save Settings on Exit option,
Quitting the application, 
then restarting it.    

Save Settings on Exit
Turns off and on the option to save the current settings when you exit the application.    Turning this option
on will save the settings that define your Mom for Windows environment.



User Setup Options 

Enable Timer Functions
Checking this option enables the timer functions.    Timer functions include displaying the current time, 
using events with alarms, and using the Notes Auto Timed Save option.    This option should normally be 
checked but doing so uses more of your system's memory.    If you are running short on RAM, you might 
try turning this option off.

Load Maximized
Checking this option will cause the application to be loaded maximized when first started.

Show Date
Show Time
Checking these options will cause the current date and/or current time to be displayed as the Icon's 
caption when minimized.

Auto Backup
This option determines if backup copies of the Events and Names database and Notes file are made each
time you start the application.    The Events and Names database backup copy is named MOMDATA.BAK 
and the Notes file backup is named MOMNOTES.BAK.    If your primary files become corrupted, you can 
try copying the backup file(s) to the primary names (MOMDATA.MDB, MOMNOTES.TXT).

Notes Auto Timed Save / Minutes
These options determine if, and how often, the Notes are automatically saved to their file.    The Enable 
Timer Functions option must be checked to use the Auto Timed Save options.    Note: Changes made to 
the Events and Names database are saved at the time the changes are made.

See Also
Autodial Options
Events Options
Names Options
Month and Year Fonts
Using Categories
MOMWIN20.INI



Autodial Options
You need a Hayes or Hayes-compatible modem to autodial telephone numbers.

Prefix
This is the prefix the autodialer uses when dialing telephone numbers.    If you normally dial a number (like
"8" or "9") to first get an outside line, you should enter that number here followed by a comma.    The 
comma causes the modem to pause before dialing the rest of the number.

Use Prefix
Check this option if you want the autodialer to use the prefix entered above when dialing telephone 
numbers.

Dial Type 
Choose either Tone or Pulse depending on your telephone line type.

Baud Rate
Chose the baud rate of you modem.

Port
Chose the port your modem is connected to.

See Also
User Setup Options
Events Options
Names Options
Month and Year Fonts
Using Categories
MOMWIN20.INI



Events Options

Time Scroll Increment
This option indicates the number of minutes to scroll the time in the Add Event and Update Event dialog 
boxes when the spin buttons are clicked or the arrow keys are pressed. 

Remove Event Days
This option indicates how many days to retain expired Events in the database.    For example, to keep all 
events for approximately one month after they have expired enter 30 here.

Show in Events Viewer
These options allow you to customize the contents and size of the Events Viewer.    The Events Viewer 
can display up to six columns.    Choose a field to display in each column from the available list and 
choose a width for each column.    Width is approximately equal to the number of characters to display.

Lines between cells
This option indicates if lines should be drawn around cells in the Events Viewer.    

Snooze Minutes
This option determines the number of minutes to snooze an alarm for an Event when its alarm goes off.

Number of Beeps
This option indicates the number of times to beep the system speaker or the number of times to play a 
sound file when an Event's alarm goes off and the sound indicator is set.    

Beep / Play Sound
Sound File
These options determine if a sound file should be played (instead of beeping the speaker) when an alarm 
goes off.    

Early Warning Days
Early Warning Minutes
These options indicate the default values for the Early Warning Days and the Early Warning Minutes 
fields in the Add Event dialog box.    

See Also
User Setup Options
Autodial Options
Names Options
Month and Year Fonts
Using Categories
MOMWIN20.INI



Names Options

Show in Names Viewer
These options allow you to customize the contents and size of the Names Viewer.    The Names Viewer 
can display up to six columns.    Choose a field to display in each column from the available lists and 
choose a width for each column.    Width is approximately equal to the number of characters to display.    
Field Name/Address displays the entire name and address in one column, field Address displays all 
addresses in one column, and field Phones displays all phone numbers in one column.

Lines between cells
This option indicates if lines should be drawn around cells in the Names Viewer.

User Field Labels
These options indicate the labels that should be used for the user-defined fields in the Names Viewer, and
the Add Name and Update Name dialog boxes.    

See Also
User Setup Options
Autodial Options
Events Options
Month and Year Fonts
Using Categories
MOMWIN20.INI



Month and Year Fonts
You can change the font the Calendar uses to draw months and years by clicking the corresponding 
button on the User Setup Options dialog box and choosing font attributes from the Font dialog box.    A 
font size = 10 or 12 works best for months, while a font size = 8 or smaller works best for years.    

Caution! A too large font size for years can use considerable amounts of your systems memory.

See Also
User Setup Options
Autodial Options
Events Options
Names Options
Using Categories
MOMWIN20.INI



Window Commands

Cascade
The Cascade command resizes and layers open windows so that each title bar is visible.    Shortcut: Shift-
F5.

Tile
The Tile command resizes and arranges the open windows side by side in the main window. Shortcut: 
Shift-F4.

Arrange Icons
The Arrange Icons command arranges any minimized windows along the bottom of the main window.    



Using Categories

Category Filters
Each Event and Name that you add to the database can be assigned a three character category code.    
The Events and Names Viewers can optionally include/exclude specific categories by using category 
filters.    For example, you can use categories to separate your business contacts from your personal 
ones.

The category filters are accessed from the Events and Names menus.    Simply check the categories you 
want to include and un-check the categories you don't want to include.    The Events and Names Viewers 
will only display entries with categories that match the ones checked.    Additionally, the Find Event and 
Find Name dialog boxes have options that let you use the category filters.

Category Maintenance
Categories can be maintained by clicking the Categories button on the User Setup Options dialog box.    
The Categories dialog box displays. 

To add a new category:
Type in a new category in the space above the Add button.
Click the Add button.    The new category now appears in the categories list.
Click the OK button.

To delete a category.
Click the category to delete in the categories list.
Click the Delete button.    The category is removed from the list.
Click the OK button.

Only the first three characters of the category description are stored in the Events and Names database.   
It is recommended you define categories using a three character mnemonic followed by a short 
description.    For example, BUS - Business, PER - Personal.    Both the mnemonic and its description will 
appear in any drop-down list box for categories.

Note: Category filters are not used on customized SQL queries.

See Also
User Setup Options
Autodial Options
Events Options
Names Options
Month and Year Fonts
MOMWIN20.INI



Using Queries
Because Events and Names are stored in the Microsoft Access database, you can perform your own 
customized queries using SQL statements. 

To query either the Events or Names database:
First, choose Query Events or Query Names from the Events Menu or Names Menu.
Enter your query in the space provided.
Click OK.
The Events or Names Viewer displays with the results of the query.    If no matching entries are 

found, the viewers will appear empty.

Note: Category filters are not used on customized SQL queries.

See Also:
Brief Introduction to SQL Queries
SQL Query Examples



Brief Introduction to SQL Queries
SQL, or Structured Query Language, is used to query, update, and manage relational databases such as 
Microsoft Access.    The general format of an SQL query statement is:

SELECT FROM tablename 
WHERE searchconditions
ORDER BY fieldlist

Note:    The SQL statements shown in the examples are written on several lines to make them easier 
to read, but you will probably want to write SQL statements on a single line.    Also, the SQL keywords 
are shown in upper case but typing them this way isn't necessary.

SELECT FROM tablename
This part of the SQL query statement is automatically included when you query the Events and Names 
databases.

WHERE searchconditions
You use WHERE searchconditions to determine which entries from the database are included in the 
results of the query.    The SQL keyword WHERE is also automatically included when you query the 
Events and Names databases.    The general format of a search condition is:

fieldname      comparison-operator      value

Valid Events fieldnames are: 
Alarm, Category, CmdLine, Comments, Date, Desc, EarlyDays, EarlyMins, RunMin, Sound, 
SoundFile, Time, and Type.

Valid Names fieldnames are:
Addr1, Addr2, Addr3, Addr4, Category, Comments, Name, Phone1, Phone2, Phone3, Phone4, User1,
and User2.

The following example queries the Events database for "all events with a BUS category":
SELECT FROM Events WHERE
Category = "BUS"

Other comparison-operators include:
< less than
<= less than or equal to
> greater than
>= greater than or equal to
= equal to
<> not equal to

The keywords LIKE and NOT LIKE can also be used as comparison-operators.    LIKE is similar to = 
(equal to) except that value can appear anywhere in the field if you enclose it in * (asterisks).    The 
following example queries the Events database for "any events that contain the character string 
birthday in their description":

SELECT FROM Events WHERE



Desc LIKE "*birthday*"

ORDER BY fieldlist
ORDER BY sorts the results of the query in the order specified in the clause.    ORDER BY is optional.    If 
you don't include it, the data appears unsorted.    The default sort order is ascending (A-Z, 0-9).    
However, you may want to include the ASC reserved word at the end of each field you want to sort in 
ascending order.    To sort in reverse order (Z-A, 9-0), add the DESC reserved word to the end of each 
field you want to sort in descending order.    

The following example queries the Names database for "people named Bob" and sorts the results in 
ascending order by Name, descending order by Addr1:

SELECT FROM Names WHERE
Name LIKE "*Bob*"
ORDER BY Name ASC, Addr1 DESC

See Also:
Using Queries
SQL Query Examples



SQL Query Examples

Events Examples

Select only Events with alarms:
Alarm = TRUE

Select only monthly Events, sorted descending by category:
Type = "M" ORDER BY Category DESC

Select only Events that run other programs, sorted ascending by date and time:
CmdLine <> "" ORDER BY Date ASC, Time ASC

Select only Events that contain the character string "call" for the month of December:
MONTH(Date) = 12 AND Desc LIKE "*call*"

Find Bob's Birthday:
Desc LIKE "*bob*" and Desc LIKE "*birthday*"

Select only Events that occur on October 10th, 1993 before 11:00am:
Date = #Oct 10, 1993# AND Time < #11:00am#

Note: Date and time values are enclosed in # (pounds) instead of " (quotes).

Names Examples

Select only Names that begin with the letter A:
Name LIKE "a*"

Select only Names with Category = FAM or PER, sorted in descending order by name:
Category = "FAM" or Category = "PER" ORDER BY Name DESC

Select only names like Robert Smith or Bob Smith:
(Name LIKE "*robert*" OR Name LIKE "*bob*") AND (Name LIKE "*smith*")

Select only Category = BUS Names that live on Main Street:
(Category = "BUS") AND (Addr1 like "*main*" or Addr2 like "*main*")

Select only Names with comments like "owes money", sorted ascending by Phone1:
Comments LIKE "*owe*" AND Comments LIKE "*money*" ORDER BY Phone1

Select only Names that have something in User1, sorted ascending by Name:
NOT ISNULL (User1) ORDER BY Name



See Also:
Using Queries
Brief Introduction to SQL Queries



Using the Toolbar

Displays the current date and time.    The date is 
formatted according to the Long Date setting in the International section of the Windows Control Panel.    
The time is formatted using either a 12 or 24 hour clock depending on the Time setting in the International
section of the Windows Control Panel.

Displays the calendar. Keyboard Shortcut: Ctrl+M or Ctrl+Y.

Displays all up-coming events.    Keyboard Shortcut: Ctrl+C.

Displays all events for today.    Keyboard Shortcut: Ctrl+T.

Displays all events for the date currently selected on the Calendar.    Keyboard Shortcut: Ctrl+S.

Displays all the events.    Keyboard Shortcut: Ctrl+L.

Displays the Names Viewer.    Shortcut: Ctrl+N.

Displays the Notes Editor.    Shortcut: Ctrl-O.

Displays the Add Event dialog box.    Shortcut: Ctrl+E or double-click a day in the Calendar while 
holding down the Shift key.

Displays the Add Name dialog box.    Shortcut: Ctrl+A.

Displays a dialog box then searches for names containing the specified characters or words.    
Only the name field is searched.    The update dialog box is displayed for any match.    Press F3 or click 
the Find Next button from the update dialog box to find the next match.    Press Shift-F3 or click the Find 
Prev button from the update dialog box to find the previous match.    Shortcut: Ctrl-F.

Displays the Help Search dialog box.

See Also
Commands



Importing Names
Importing Names allows you to add Names to the Mom for Windows Names database by importing them 
from a comma-delimited ASCII text file.    Comma-delimited ASCII text files are a common format that is 
used to share data between different applications.    You can import Names from other applications as 
long as they support exporting this file format.    Comma-delimited ASCII text files can also be created and
edited using any ASCII text editor such as Windows Notepad.    Importing adds new Names for each 
record in the import file to the existing Names in the Mom for Windows database.    

Caution!    Be sure to make a backup copy of MOMDATA.MDB before importing names.

To import Names:
First, create a comma-delimited ASCII text file as described above.
Determine the order of the fields in the import file.    Field order can be determined by simply 

viewing the import file using an ASCII text editor.
Choose Import Names from the File menu.    The Import Names dialog box displays.
Enter a valid file name for the import file.    The default is IMPORT.TXT.
Indicate how the fields in the import file should be mapped to the fields in the Mom for Windows 

Names database by changing Field Nbr's on the Import Names dialog box.    For example, if the second 
field in the import file contains a phone number you should change Field Name Phone1 to be Field Nbr 2. 
Leave Field Nbr equal to 0 for fields that are not mapped from the import file.

Click the Import button.    The status bar is updated to show when all names have been imported. 
Click the Close button.

Comma-delimited ASCII text files consist of each field enclosed in quotes (") and separated by commas 
(,).    Fields that do not contain values can be imported as #NULL# or "".    Each record in the import file 
represents one record in the Names database.    A sample import file (IMPORT.TXT) is included that lets 
you practice importing Names.    Here's how the first three records look in the sample import file:

"AST Research, Inc. - Irvine","16215 Alton Pkwy","P.O. Box 19658","Irvine, CA 
92713-9658","714-863-1333","714-727-4141",""

"AT&T Computer Systems","1 Speedwell Ave.","Morristown, NJ 07960","","800-247-1212 
sales","",""

"Bitstream Inc.","Athenaeum House","215 First St.","Cambridge, MA 02142","800-522-
3668","617-497-6222","font sftw"

Note: The fields in the sample import file are in the following order: 
Name, Addr1, Addr2, Addr3, Phone1, Phone2, Phone3, and Comments.    Fields not imported are:    
Addr4, Category, Phone4, User1, and User2.

See Also
Exporting Names



Exporting Names
Exporting Names allows you to copy the contents of the Mom for Windows Names database to other 
applications by first creating a comma-delimited ASCII text file.    Comma-delimited ASCII text files are a 
common format that is used to share data between different applications.    You can share the Names with
other applications as long as they support importing this file format.    Exporting copies all the Names to 
the export file and does not remove them from the Mom for Windows database.    

To create an export file:
Choose Export Names from the File menu.    The Export Names dialog box displays.
Enter a valid file name for the export file.    The default is EXPORT.TXT.
Click the Export button.    The status bar is updated to show when the export file has been 

created.
Click the Close button.

Comma-delimited ASCII text files consist of each field enclosed in quotes (") and separated by commas 
(,).    Fields that do not contain values are exported as #NULL#.    Each record in the export file represents 
one record in the Names database.    The fields in the exported records are in the following order: Addr1, 
Addr2, Addr3, Addr4, Category, Comments, Name, Phone1, Phone2, Phone3, Phone4, User1, and 
User2.

Here's how three records might look in a Mom for Windows export file:

"16215 Alton Pkwy", "P.O. Box 19658", "Irvine, CA 92713-9658", #NULL#, #NULL#, 
#NULL#, "AST Research, Inc. - Irvine", "714-863-1333", "714-727-4141", #NULL#, 
#NULL#, #NULL#, #NULL#

"1 Speedwell Ave.", "Morristown, NJ 07960", #NULL#, #NULL#, #NULL#, #NULL#, "AT&T 
Computer Systems", "800-247-1212 sales", #NULL#, #NULL#, #NULL#, #NULL#, #NULL#

"Athenaeum House", "215 First St.", "Cambridge, MA 02142", #NULL#, #NULL#, "font 
sftw", "Bitstream Inc.", "800-522-3668", "617-497-6222", #NULL#, #NULL#, #NULL#,
#NULL#

Note: These samples were created by first using Mom for Windows to import the sample import file 
(IMPORT.TXT) and then to export it.

See Also
Importing Names



Converting from Mom for Windows version 1.0
Mom for Windows version 2.0 comes with a conversion program that can be used to convert the Events 
and Names files from Mom for Windows version 1.0 to the version 2.0 database format.    This conversion 
program can also be used to remove all Events and/or all Names from the version 2.0 database, 
essentially re-initializing the database.

The conversion program is named CONVERT.EXE (of course).    Run it like you would run any other 
Windows program and follow its directions. 

Caution!    Be sure to make a backup copy of MOMDATA.MDB before running the conversion program.

See Also
What's New?



Uninstalling Mom for Windows
Should you decide to remove Mom for Windows from your system, you can do so by simply deleting the 
files that came with it.    To uninstall Mom for Windows:

Delete the Mom for Windows version 2.0 (MOMWIN20) directory and its contents.    
Delete MOMWIN20.INI from your Windows directory.
Delete the following Visual Basic custom controls (VBXs) and run-time dynamic linked libraries 

(DLLs) in your Windows System directory:

3DLABEL.VBX, CMDIALOG.VBX, COMMDLG.DLL, GRID.VBX, MASKTEXT.VBX, 
MMSYSTEM.DLL, MSAES110.DLL, MSAJT110.DLL, SPIN.VBX, THREED.VBX, VBDB300.DLL, 
and VBRUN300.DLL.

Caution!  There's a good chance you have other applications that use these files.    You should 
copy them to a backup directory before deleting them from the Windows System directory.    If you
get errors from other applications, you can easily put the necessary files back.    Once you are 
confident the files aren't needed, you can safely delete them from the backup directory.



MOMWIN20.INI
This section documents the options and settings in the MOMWIN20.INI file.    MOMWIN20.INI contains 
information that defines your Mom for Windows environment.    MOMWIN20.INI must be installed in the 
Windows directory.    

All of the options in MOMWIN20.INI can be accessed from the menu.    All entries and their defaults are 
listed alphabetically below.    For options that have either a yes or no value, a "1" indicates yes and a "0" 
indicates no.

AutoBackup=0
This option determines if backup copies of the Events/Names database and Notes file are made when 
you first start the application.    This option can be changed from the User Setup dialog box.

AutoDialBaudRate=1200
AutoDialComPort=COM1
AutoDialPrefix=9
AutoDialTypeTone=1
AutoDialUsePrefix=0
Modem settings for the phone number autodialer.    These options can be changed from the Autodial 
Options dialog box.

AutoTimedSave=0
AutoTimedMinutes=30
These options determine if, and how often, the Notes are automatically saved to their file.    These options
can be changed from the User Setup dialog box.

CalendarHeight=3915
CalendarLeft=990
CalendarTop=990
CalendarWidth=6630
The position and dimensions for the Calendar.    These settings are changed when you choose Save 
Settings Now  from the Options menu or when you exit Mom for Windows with the Save Settings on Exit 
option set.

CalendarMode=M
This setting determines the mode of the Calendar if it is loaded when the application starts.    Valid values 
are:

"M" - view current month
"Y" - view current year

This setting is changed when you choose Save Settings Now from the Options menu or when you exit 
Mom for Windows with the Save Settings on Exit option set.

CalendarVisible=1
This setting indicates if the Calendar is visible when the application starts.    This setting is changed when 
you choose Save Settings Now from the Options menu or when you exit Mom for Windows with the Save 
Settings on Exit option set.

CalendarWindowState=0
This setting indicates the window state of the Calendar when it is initially loaded.    Valid values are:

0 - (Default) Normal



1 - Minimized
2 - Maximized

This setting is changed when you choose Save Settings Now from the Options menu or when you exit 
Mom for Windows with the Save Settings on Exit option set.

Categories=BUS - Business,FAM - Family,PER - Personal,
This option indicates the list of categories that are available for Events and Names.    Categories are 
separated by commas.    Note that only the first three characters of a category are saved with an Event or 
Name.    Categories can be changed from the Categories dialog box.

EnableTimer=1
This option determines if the timer functions are enabled.    This option can be changed from the User 
Setup dialog box.

EventEarlyDays=10
EventEarlyMins=10
These options indicate the default values for the Early Warning Days and the Early Warning Minutes 
fields in the Add Event dialog box.    These options can be changed from the Events Options dialog box.

EventsCategories=1000
This setting indicates which category filters are selected for Events.    There is one digit for each available 
category (including All Categories).    A value of "1" means the category is selected and a value of "0" 
means the category is not selected.    Event categories are selected from the Events menu.    This setting 
is changed when you choose Save Settings Now from the Options menu or when you exit Mom for 
Windows with the Save Settings on Exit option set.

EventScrollMins=10
This option indicates the number of minutes to scroll the time in the Add Event and Update Event dialog 
boxes when the spin buttons are clicked or the arrow keys are pressed.    This option can be changed 
from the Events Options dialog box.

EventsHeight=3915
EventsLeft=0
EventsTop=0
EventsWidth=6630
The position and dimensions for the Events Viewer.    These settings are changed when you choose Save
Settings Now from the Options menu or when you exit Mom for Windows with the Save Settings on Exit 
option set.

EventsLines=1
This option indicates if lines should be drawn around cells in the Events Viewer.    This option can be 
changed from the Events Options dialog box.

EventsMode=U
This setting determines the mode of the Events Viewer if it is loaded when the application starts.    Valid 
values are:

"A" for All Events
"Q" for Query Events
"S" for Selected Date's Events
"T" for Today's Events



"U" for Up-Coming Events
This setting is changed when you choose Save Settings Now from the Options menu or when you exit 
Mom for Windows with the Save Settings on Exit option set.

EventsQuery=Desc like '*birthday*'
This option stores the last query that was performed on the Events database.    This setting is changed by 
using the Query Events dialog box.

EventsVisible=1
This setting indicates if the Events Viewer is visible when the application starts.    This setting is changed 
when you choose Save Settings Now from the Options menu or when you exit Mom for Windows with the 
Save Settings on Exit option set.

EventsWindowState=0
This setting indicates the window state of the Events Viewer when it is initially loaded.    Valid values are:

0 - (Default) Normal
1 - Minimized
2 - Maximized

This setting is changed when you choose Save Settings Now from the Options menu or when you exit 
Mom for Windows with the Save Settings on Exit option set.

IconShowDate=1
IconShowTime=1
These options indicate if the icon should display the current date and/or time when minimized.    These 
options can be changed from the User Setup dialog box.

LoadMaximized=0
This option indicates if the application should be loaded maximized when first started.    This option can be
changed from the User Setup dialog box.

MainHeight=6690
MainLeft=75
MainTop=45
MainWidth=8400
The position and dimensions for the MDI (Multiple Document Interface) window.    These setting are 
changed when you choose Save Settings Now  or when you exit Mom for Windows with the Save 
Settings on Exit option set.

MonthFontBold=1
MonthFontItalic=0
MonthFontName=MS Sans Serif
MonthFontSize=12
These options indicate the font that is used by the Calendar to draw the month.    These options can be 
changed by clicking the Month Font button on the User Setup dialog box.

NamesCategories=1000
This setting indicates which category filters are selected for Names.    There is one digit for each available 
category (including All Categories).    A value of "1" means the category is selected and a value of "0" 
means the category is not selected.    Name categories are selected from the Names menu.    This setting 
is changed when you choose Save Settings Now  or when you exit Mom for Windows with the Save 



Settings on Exit option set.

NamesHeight=3915
NamesLeft=330
NamesTop=330
NamesWidth=6630
The position and dimensions for the Names Viewer.    These settings are changed when you choose Save
Settings Now  or when you exit Mom for Windows with the Save Settings on Exit option set.

NamesLines=1
This option indicates if lines should be drawn around cells in the Names Viewer.    This option can be 
changed from the Names Options dialog box.

NamesMode=All
This setting determines the mode of the Names Viewer if it is loaded when the application starts.    Valid 
values are:

"All" -    All Names
"Query" -    Query Names
"any letter" - Names beginning with that letter

This setting is changed when you choose Save Settings Now from the Options menu or when you exit 
Mom for Windows with the Save Settings on Exit option set.

NamesQuery=Name like '*bob*' and Addr1 like '*main*'
This option stores the last query that was performed on the Names database.    This setting is changed by
using the Query Names dialog box.

NamesUser1Label=User1
NamesUser2Label=User2
These options indicate the labels that should be used for the user-defined fields in the Names Viewer, and
the Add Name and Update Name dialog boxes.    These options can be changed from the Names Options
dialog box.

NamesVisible=1
This setting indicates if the Names Viewer is visible when the application starts.    This setting is changed 
when you choose Save Settings Now  or when you exit Mom for Windows with the Save Settings on Exit 
option set.

NamesWindowState=0
This setting indicates the window state of the Names Viewer when it is initially loaded.    Valid values are:

0 - (Default) Normal
1 - Minimized
2 - Maximized

This setting is changed when you choose Save Settings Now from the Options menu or when you exit 
Mom for Windows with the Save Settings on Exit option set.

NbrAlarmBeeps=10
This option indicates the number of times to beep the system speaker or the number of times to play a 
sound file when an Event's alarm goes off and the sound indicator is set.    This option can be changed 
from the Events Options dialog box.



NotesHeight=3915
NotesLeft=660
NotesTop=660
NotesWidth=6630
The position and dimensions for    the Note Editor.    This setting is changed when you choose Save 
Settings Now from the Options menu or when you exit Mom for Windows with the Save Settings on Exit 
option set.

NotesVisible=1
This setting indicates if the Note Editor is visible when the application starts.    This setting is changed 
when you choose Save Settings Now from the Options menu or when you exit Mom for Windows with the 
Save Settings on Exit option set.

NotesWindowState=0
This setting indicates the window state of the Notes Editor when it is initially loaded.    Valid values are:

0 - (Default) Normal
1 - Minimized
2 - Maximized

This setting is changed when you choose Save Settings Now from the Options menu or when you exit 
Mom for Windows with the Save Settings on Exit option set.

PageFontBold=0
PageFontItalic=0
PageFontName=Arial
PageFontSize=10
These options indicate the font that is used when printing.    This option can be changed from the Page 
Setup dialog box.

PageMarginBottom=1440
PageMarginLeft=1440
PageMarginRight=1440
PageMarginTop=1440
These options indicate the margins that are used when printing.    The margins are stored in twips.    There
are approximately 1440 twips per inch and 567 twips per centimeter.    These options can be changed 
from the Page Setup dialog box.

PlaySound=0
PlaySoundFile=C:\WINDOWS\CHIMES.WAV
These options determine if a sound file should be played (instead of beeping the speaker) when an alarm 
goes off.    These options can be changed from the Events Options dialog box.

RemoveEventsDays=30
This option indicates how many days to retain expired Events in the database.    This option can be 
changed from the Events Options dialog box.

SaveSettingsOnExit=0
This option indicates if the application settings should be saved when you exit.    This option can be 
changed from the Options menu and is saved each time you exit Mom for Windows.



ShowEventsList=Date,Time,Type,Desc,(nothing),(nothing),
These options determine which fields are displayed in the Events Viewer.    Each field name is separated 
by a comma.    This option can be changed from the Events Options dialog box.

ShowEventsWidth=7,7,4,45,1,1,
These options determine the width of each column in the Events Viewer.    The number represents the 
approximate number of characters in each column.    Each column width is separated by a comma.    This 
option can be changed from the Events Options dialog box.

ShowNamesList=Name/Address,Phones,Comments,(nothing),(nothing),(nothing),
These options determine which fields are displayed in the Names Viewer.    Each field name is separated 
by a comma.    This option can be changed from the Names Options dialog box.

ShowNamesWidth=25,25,25,1,1,1,
These options determine the width of each column in the Names Viewer.    The number represents the 
approximate number of characters in each column.    Each column width is separated by a comma.    This 
option can be changed from the Names Options dialog box.

SnoozeMins=10
This option determines the number of minutes to snooze an alarm for an Event when its alarm goes off.    
This option can be changed from the Events Options dialog box.

YearFontBold=0
YearFontItalic=0
YearFontName=MS Sans Serif
YearFontSize=8
These options indicate the font that is used by the Calendar to draw years.    These options can be 
changed by clicking the Year Font button on the User Setup dialog box.

See Also
User Setup Options



 Still cheap!



You must have a sound driver installed in order to play sound files.    The Microsoft PC Speaker driver can
be used to play .WAV files through your system's speaker.    This driver is free and can be found on most 
BBS's under the name SPEAK.EXE.    Microsoft Windows comes supplied with several .WAV files you can
use on alarms.
.



Shrunk to an icon.



Enlarged to maximum size.




